swodifh1

  • Hi

    I’m trying to join the Another GameServers.com American server but it says in the master server page that it is 1.08 version. I have the original fear combat 1.08 installed but I get an error when I search for the servers. Do I need the Fear Launcher? I cannot find the Fear launcher in the downloads on this site. Any help would be great.

  • swodifh1 became a registered member 1 year, 2 months ago